AvenueK9 BuddyPress Theme

BuddyPack Light, a set of child themes for BuddyPress 1.2, is available for download here.

It’s finally done. The first incarnation of AvenueK9′s BuddyPress theme is hot off the keyboard and available for download/hackery. It’s far from perfect… and just before I started styling the BP home theme, I already started getting ideas for a newer, fancier theme. Eh. So what’s this got that the other ones don’t? A fixed width. I know that concept is rather vomit-inducing, but I really wanted to focus on continuity between AvenueK9.com and its *VIP* section. That included maintaining the container width sitewide. Since that site was optimized for those old, crappy 1024×768 monitors, the 980-pixel-wide design was carried over to theme its BP counterpart. Other changes include some switched content — mainly the masthead/logo, main navigation, login section and search box. Enjoy!

Download AveK9 BuddyPress theme

Download AvenueK9 BuddyPress theme

49 Comments

  1. david demember June 15, 2009 at 10:55 am #

    Great theme! How did you set up the home page on http://www.AvenueK9.com ? Are they plugins/widgets or a custom page template (or both?). I also like the elgg vs. Buddypress review. Very thorough, keep up the good work.

    thanks,
    dave

  2. mike June 15, 2009 at 3:54 pm #

    Thanks man! The AVE K9 homepage is a complete custom page and, yes, I’m using plugins. Tons. Lester Chan’s voting plugin for the poll. Matt Harzewski’s WP125 plugin for the square ads and Alakhnor’s Post Thumb plugin for the story teasers. Everything’s automated so that people can spend more time writing vs. cropping pics or dropping ad codes. The rest are just jQuery plugins (not WP plugins) to make everything look a bit fancier =)

    Your sites pretty sleek, too! You have a real good eye for design. Is Di-F an agency or just you at this point?

  3. raciloni July 22, 2009 at 7:35 am #

    i am trying to use this theme in an arabic website, but have problems with ie6 when flipping direction to rtl.
    any suggestion?

    • mike July 22, 2009 at 4:05 pm #

      That looks pretty awesome! Thanks for using the AveK9 theme =) My best suggestion would be to use a conditional stylesheet for IE6. Here’s a good link on how to do that… http://css-tricks.com/how-to-create-an-ie-only-stylesheet/

      I know it’s a pain in the butt, but that’s probably the best way to about handling that issue. Then again, if your IE6 user base is relatively small — say, 6% or less — I probably wouldn’t even bother. Hope that helps!

  4. Din August 5, 2009 at 3:40 am #

    hai mike.. i’m din..
    i need help from you about your Avenue K9 Themes,
    can i know how to make home page at this theme..
    please help me, i’m newbies..

  5. mike August 7, 2009 at 6:09 am #

    hey Din – once you’ve uploaded the themes to their appropriate folders, you’ll have to go into BuddyPress >> General Settings >> Select Avenue K9 (dropdown option) >> Save Settings. Then, go into Appearance >> Themes >> Avenue K9. Hope that solves it for you!

  6. MarkS August 19, 2009 at 8:53 am #

    Thanks for your work on this Theme Mike. Buddypress 1.1 will have the following features:

    “Added complete forum management for group mods and admins (sticky/delete/close/edit) and edit/delete for group members on their own posts. Make sure you update your theme with the new template files in the /groups/ directory to get access to these features.”

    Can these files be updated as is from the new template or will they need changes based on your theme?

    Do you plan on doing a similar theme for the new theme architecture?

    “there will no longer be bhome and bpmember themes. Instead, BuddyPress will adopt the parent/child theme architecture that WP 2.7 made possible.”
    http://buddypress.org/forums/topic/details-about-the-new-theme-architecture

    Again, thanks for sharing your work.

    • mike August 19, 2009 at 4:30 pm #

      Thanks for the feedback! So for the forum management group, you’d have to get those code snippets from the new template and manually add/edit them to the Avenue K9 themes to get that functionality. I’m actually not running forums on my own BP install because it’s a bit wonky at this point, which is why I’m not supporting it yet. I know that come BP 1.1+, forum integration will be a one-click install, which will make things a bit easier for everyone at which point I’ll most likely create/release the accompanying bbPress Avenue K9 theme. As to the new BP structure, I’ll definitely hop on the child theme bandwagon in re-doing this theme. At this point, I’m just waiting for 1.1 to come out first before I take a stab at it, since those nightly builds tend to change fairly frequently — I’d rather have something solid to work with before I dive straight into recoding everything =)

  7. Paul August 26, 2009 at 3:41 pm #

    Hi Mike, thanks for a great theme. I downloaded your other theme off the wordpress site, is this one a newer version?

    The reason I ask is that for the life of me I cannot get avatar cropping to work in FF. It goes all wonky and jumps all over the place. From what I read this has to do with installing a non default theme that has a fixed width. Is there any updated JS I have to install? Are you having the same issues with cropping and FF? Sorry to bother you with this, I am not sure who else to ask! Thanks again for a great bit of work.

  8. mike August 31, 2009 at 3:12 pm #

    Hey Paul – Sorry for the lag on the response. I had this set on moderated comments but just got rid of it. Actually, I don’t have any problems with the cropping using IE/FF/Opera or Chrome. I do know what what you’re referring to though. If I cropped the avatar from a different starting point, it’ll jump around like crazy just like said… BUT it also did that with the default BP theme. Anywho, I’m sure you’ve already heard that come BP 1.1 the entire theme structure will be changed, meaning that this theme will no longer work down the road. The new structure will also include jcrop, if I’m not mistaken, which might solve that weird jumpy thing that’s going on. I am actually going to take the time to sit down and recode this from the ground up once the new BP version is released, so hang in there =)

  9. Eileen September 10, 2009 at 10:34 am #

    Thanks so much for creating this theme. I’m having some minor issues, that I thought you might be able to help with. I got my masthead changed on my main page, and my blog posts, but on the members pages and others, it still shows up “Your Masthead”. I plan to use the main blog for all authors, and would like to get rid of the tab for “blogs” altogether. Those are the only glitches I’ve got so far. Thanks again for your theme, and I appreciate your response in advance!

    Eileen

    • mike September 10, 2009 at 12:51 pm #

      Thanks Eileen =) For the logo, you’ll have to edit the other image located in the avek9member >> images folder within the bp-themes directory. All you have to edit is the ave-masthead.gif … you could probably just copy over the existing one you have. As to getting rid of the blogs section, open up the header.php file and delete or comment out the lines around 56-58 which call the ‘Blogs’ section.

      You’ll also have to do that in the header.php file in the avek9home theme folder.

  10. Richard September 11, 2009 at 4:43 am #

    Hello,

    I have a little bug with this beautiful theme.

    In fact, when I am on the profil page and I clik on the blog page, I am redirecting on the home page.

    Do you know how can I fix this bug?

    Thank you very much!

    • mike September 11, 2009 at 10:11 am #

      Thanks Richard =) My first suggestion would be to see that you have Blogs enabled under Site Admin >> Site Options (Allow new registrations: Enabled. Blogs and user accounts can be created.). If you have other WP/WPMU installations on your domain, this could also be a factor in why you’re getting that bug. Best way to use BP is in the root like http://www.yourbpsite.com.

  11. Richard September 11, 2009 at 12:16 pm #

    Yes I have Blogs enable because when I clik on Blog when I am on the home page it’s ok .

    I have bug only when I clik on Blog when I am on members, groups and profile page.

    I have only one WPMU installation on my http://www.example.com .

    Thank you for your help

  12. mike September 11, 2009 at 1:26 pm #

    alright, try using the default BP theme and see if you get the same error… trying to think what it could be

  13. Richard September 11, 2009 at 1:46 pm #

    When I using the defaut theme it is ok.

    But the BP defaut theme sucks…

    You have an idea?

    Thank you

  14. mike September 11, 2009 at 2:04 pm #

    Would you mind sharing your link? If you don’t want to put it in here you can email it to me at ###

  15. Richard September 11, 2009 at 2:20 pm #

    I send you an email

  16. Gino November 20, 2009 at 7:21 am #

    Hi Michael,

    Great theme, thanks for making it available. Seems easier for a hacker (WP hacker that is) to customize it. I’m just having one slight bit of trouble. The front page widgets don’t seem to be working properly. I have put a widget in the first-section side bar but it’s not showing up. It just says on the page “Please log in to add widgets to this section” Just wondering if you know how I can fix this?

    Thanks so much, Gino.
    Gino

  17. Jennifer November 20, 2009 at 9:48 pm #

    Forgive me for being an idiot – I am new to Buddypress. I am trying to install this theme and downloaded avenuek9.zip. I followed the instructions, but wordpress says “Template is missing”, which I assume is due to the lack of an index.php file. Am I supposed to install avek9-bp-theme.zip and replace certain files with the ones found in avenuek9.zip? If so, how do I go about this? Following the directions that come with avenuek9.zip (simply adding to themes directory) does not work. I tried installing avenuek9-bp-theme.zip first, and that does not work either. I am able to activate and implement avek9home, not avenuek9…but the result is a completely blank page.

    Hopefully that makes sense. I’m sure I’m doing something very simple wrong, but I can’t figure it out for the life of me. Any insight would be greatly appreciated.

  18. Jennifer November 21, 2009 at 8:43 am #

    Just to update, I discovered my problem (stupid mistake) and now your theme is up and running just fine. I did not realize that the Buddypress parent theme needed to be installed in wp-content/themes. Somehow I had come across older documentation for Buddypress, and was following that. Since the old BP theming setup is still in place, it took me a while to realize the error of my ways. I’m sure there’s a technical reason why the plugin installer can’t set up up correctly to begin with, but that sure would be nice.

  19. James November 30, 2009 at 11:45 pm #

    Nice AvenueK9 i’m playing with it now at http://toptengiftsformen.com. What is the sliding effect you have on this site though. What plugin is it? or is it a custome jquery jflow you created? Does it improve page load time?

    • mike December 6, 2009 at 9:55 pm #

      it’s custom jquery… preloads content with the help of some ajax =)

  20. locolbd January 20, 2010 at 6:54 pm #

    Okay i am trying to install the avenuek9 theme for WordPress MU with buddypress incorporated.

    When i install the theme via buddypress admin backend, i am prompted with a message saying that avenuek9 is broken, it needs a stylesheet and a template

    Can someone help

  21. tinto January 24, 2010 at 9:45 am #

    Hi Locolbd,
    Copy and paste bp-sn-parent from plugins/buddypress/themes to wp-content/themes , that should correct the problem.
    Regards,
    Tinto

  22. steven February 1, 2010 at 12:18 am #

    @ tinto Thank you for that. Saved me ! But why does this happen? Why is the folder in that spot? Thanks in advance.

  23. Michael February 19, 2010 at 5:49 am #

    Hi,
    Great work there though unfortunatly been able to view thumbnails only and failed to install any of the them…..

    1. Am using the latest buddypress.
    2. i navigated to the add new plugin and installed.
    3. Wen i activate it, it says…….

    “The plugin does not have a valid header”

    What am i doing wrong. KIndly guide me. Thanks

  24. mike February 20, 2010 at 3:01 pm #

    @Michael – Hey there, I’m almost betting your Default BP installation isn’t working properly either, since Avenue K9 and Fishbook are only child themes.That is, both of them use your Default BP theme header while changing the design only through CSS. I would recommend deleting your buddypress plugin folder and reinstalling everything. I remember I had the same problem and that actually did the trick, although, you’ll have to upload a new copy of bbpress as well if you want to retain your forums.

  25. John March 17, 2010 at 1:50 pm #

    I am having the same problem jennifer had except I DO have a bp-sn-parent theme in wp-content/themes.

    Whenever I try to install any of the buddypack I get that it “template is missing”

    any help here?

  26. PiterJankovich March 29, 2010 at 4:00 pm #

    My name is Piter Jankovich. oOnly want to tell, that your blog is really cool
    And want to ask you: is this blog your hobby?
    P.S. Sorry for my bad english

  27. mike March 29, 2010 at 8:35 pm #

    Thanks Piter! Yes, it’s just a hobby =) I love to design and market, and I love the ease of use for WordPress/BuddyPress!

  28. Will Chapman April 17, 2010 at 6:50 pm #

    Mike

    I have finally got Buddypress working (the problem was incompatibility with a windows host running IIS) by switching to a Linux host. I am using plain WP (2.9.2) and BuddyPress 1.2.3

    I have installed Avenue K9 but when I try to change the header I get:

    “You do not have sufficient permissions to access this page”

    How do I fix this, or alternatively, where do I put the replacement image.

    By the way, I also tried to install Gates but I got an error indicating that the theme couldn’t be saved.

    Cheers

    Will

  29. Michael Kuhlmann April 19, 2010 at 10:25 pm #

    @Will – Great to hear that you’ve got BP up and running! It sounds like all the permission errors you’re getting seem to come from your chmod levels in your directories. You could change everything to 755/777, depending how you’re set up, but I like to edit through FTP straight so that you don’t have to mess with that all the time. As to changing the header image, the header image file is located in the avenuek9 theme folder under the filename header.gif in the root directory. For Gates, I’d again try to edit it straight with your FTP/html editor, so give that a try and see how it works.

  30. KevinL July 31, 2010 at 5:08 pm #

    Hi Michael

    I don’t know whether you could advise but I am using BP with AvenueK9 and have a problem with the highlighting of menu items. For BP items (e.g. Home, Members), the menu item is highlight when on that page (with the “selected” attribute). However, for pages I’ve created, the menu item is not highlighted even though the item has the current_page_item class but no “selected” attribute. I can’t find where current_page_item is defined and whether I just need to amend something to add “selected” somewhere.

    Many thanks
    Kevin

  31. Michael Kuhlmann August 3, 2010 at 10:07 am #

    Hey Kevin – Sorry about the lag on here. It’s been a hectic few weeks for me. Anyway, to solve your problem, open up your style.css file from your theme folder. Next, locate the line that start with ul#nav li.selected a in the Navigation section. Then, add a comma and write ul#nav li.current_page_item a, so that it reads ul#nav li.selected a, ul#nav li.current_page_item a { … } . That should do it for you.

  32. KevinL August 3, 2010 at 10:51 am #

    @Michael: Fantastic! Thank you for your response and your theme!

  33. KevinL February 26, 2011 at 11:29 am #

    Hi Michael
    I’m using BP with AvenueK9. When I display a list of posts, I want to only show a summary/the first 100 so characters of each post with a More… link.
    I have tried entering an excerpt for the posts but that doesn’t seem to work.
    As I’m relatively new to WP/BP, am I missing a basic setting in WP/BP or AvenueK9 or does it need some special customisation?
    Thanks
    Kevin

  34. Mike February 26, 2011 at 1:29 pm #

    @KevinL – I’m pretty sure you could pull this off with a custom function, but for the quick and dirty way, I’d suggest using The Advanced Excerpt plugin (http://wordpress.org/extend/plugins/advanced-excerpt/), which you can infinitely tweak for each excerpt.

  35. KevinL February 27, 2011 at 3:19 pm #

    @Michael: Thanks for the suggestion Michael. However, I found that all I needed to do was use the tag in my posts – I hadn’t come across this before! The WP development community is truly amazing!

  36. KevinL February 27, 2011 at 3:25 pm #

    @Michael: Posting my previous reply removed the ‘more’ tag – the one with the chevrons/dashes before and after it, if you know what I mean – http://en.support.wordpress.com/splitting-content/more-tag/

    • Mike February 27, 2011 at 8:28 pm #

      Ah yeah! I totally misunderstood your question =)

  37. ping September 25, 2011 at 1:49 pm #

    hi mic, thanks for the great work, how can we update this theme for bp 1.5

    regards

    • Mike September 26, 2011 at 1:41 am #

      Hey Ping – If you’re a WP/BP greasemonkey, you should be able to make this theme work again by creating a function file that overrides BP Default theme’s (Dtheme) CSS rules. Then, you’ll have to reload the Avenue K9 stylesheet, since that was originally called from the Dtheme. Work’s been pretty crazy on my end, so I haven’t gotten around to updating my four themes yet on WP repo, but I will definitely do so and resubmit once my schedule frees up again =)

Trackbacks/Pingbacks

  1. BuddyPress Links #22 · Buddypress Links - June 12, 2009

    [...] BuddyPress theme released [...]

  2. 10 Thèmes pour BuddyPress | BuddyGrid - June 14, 2009

    [...] Michael Kuhlmann propose un thème pour BuddyPress appellé K9 Avenue. [...]

  3. links for 2009-06-16 — Chroniques du web - June 16, 2009

    [...] AvenueK9 BuddyPress Theme Un thème BuddyPress dérivé du thème par défaut (tags: buddypress theme) [...]

Leave a Reply